Elevated API Errors

Incident Report for JobNimbus

Resolved

The issue has been resolved.

Root Cause
From 11:53am to 12:53pm MDT we experienced a temporary service disruption to the Estimating platform due to an unexpected load on our backend systems. This unexpected load briefly affected system performance and availability. The primary incident was identified and resolved quickly, but lingering processing delays inhibited normal usage. We’re implementing additional safeguards to prevent this type of issue in the future, including improved monitoring and better resource management.

A backlog of queued items needed to be processed post incident. This backlog finished processes at 3:21pm MDT. All Estimate actions were processed.

We understand the importance of reliability and sincerely apologize for any disruption this may have caused. Thank you for your patience and continued partnership.
Posted Jun 20, 2025 - 15:28 MDT

Update

We are continuing to monitor for any further issues.
Posted Jun 20, 2025 - 13:23 MDT

Update

We are seeing full recovery within the Estimating platform and are monitoring closely to confirm full resolution.
Posted Jun 20, 2025 - 13:17 MDT

Monitoring

We have been experiencing an elevated number of API errors in the Estimating service since 11:53am MT. A possible root cause has been identified and some recovery has been observed during the last 7 minutes but we are continuing to monitor closely.
Posted Jun 20, 2025 - 12:45 MDT
This incident affected: Web Application Performance.