JobNimbus is currently experiencing intermittent login issues with Payments
Incident Report for JobNimbus
Resolved
Payment processing and logging into the payments portal should be restored to full service. We will continue to monitor for any difficulties. Thank you again for your patience!
Posted Mar 30, 2023 - 10:26 MDT
Investigating
JobNimbus is experiencing intermittent issues with logging into JN payments portal.

Our team is working to restore service as quickly as possible. We apologize for any inconvenience.
Posted Mar 30, 2023 - 09:43 MDT
This incident affected: Login and Receiving Payments.