Increased Latency

Incident Report for JobNimbus

Resolved

Metrics continue to indicate improvements to read latency. We are resolving this status but will still be watching tomorrow’s performance closely.

Thank you for your understanding and patience.
Posted Dec 02, 2025 - 19:44 MST

Update

We will keep this monitoring ticket open and post one more update this evening, but are so far seeing metrics improve as we expect.
Posted Dec 02, 2025 - 16:35 MST

Update

Metrics show improved performance in the areas of concern. We are continuing to monitor to validate these findings.
Posted Dec 02, 2025 - 13:28 MST

Update

We are continuing to monitor performance closely and are observing decreased read latency overall. We will post another update in 2 hours. Thank you for your patience.
Posted Dec 02, 2025 - 10:15 MST

Monitoring

We have been observing increased read latency in an underlying data source. We have identified a likely root cause, made system adjustments overnight, and are monitoring performance closely. Isolated customers may experience slower page loads or data retrieval. No disruption of saves, uploads, or similar has been observed.

We will post updates throughout the day. Thank you for your patience.
Posted Dec 02, 2025 - 07:31 MST
This incident affected: Web Application Performance and Public API - Application Programming Interface.