We have seen full recovery and confirmed that full functionality has been restored to the app.
A full RCA will be posted within 48 hours.
Thank you for your patience and your trust in JobNimbus.
Posted Sep 16, 2026 - 15:50 MDT
Update
We continue to see accelerated recovery and expect full recovery in the next few hours.
No data was lost, but processing was delayed. Customer access records will self-correct as processing catches up.
Posted Sep 16, 2026 - 15:27 MDT
Monitoring
We are seeing initial stages of recovery after mitigation efforts. We continue to monitor and will provide updates as soon as we can
Posted Sep 16, 2026 - 15:02 MDT
Identified
The root cause has been identified. Mitigating steps are being taken. We will post an expected resolution timeframe once that is known.
Posted Sep 16, 2026 - 14:19 MDT
Investigating
A delay in processing background operations is preventing newly created estimates from appearing for limited access users. We are actively investigating the issue and will post updates here as soon as we know more.