JobNimbus is currently experiencing issues with Digital Signatures and Sales Dashboard based on location
Incident Report for JobNimbus
Resolved
A fix has been implemented by JobNimbus and we've restored functionality to digital signatures and sales dashboards for all our customers. Thank you again for your patience during this time!
Posted Feb 21, 2023 - 17:24 MST
Identified
We've identified the cause of the issue and are working on the solution.
Posted Feb 21, 2023 - 14:47 MST
Investigating
JobNimbus is experiencing an issue with digital signatures in estimates and proposals, as well as the Sales Dashboard. This is causing a loss of functionality to these areas of the app for some of our customers based in various locations. This does not affect our mobile apps.

Our team is working with one of our technology partners to restore service as quickly as possible. We apologize for any inconvenience.
Posted Feb 21, 2023 - 14:47 MST
This incident affected: Web Application Performance.