The fix has been deployed to Production and the issue is resolved. An issue with a 3rd party service caused failures in the loading of the primary site. The engineering team is updating how this service integrates with our frontend to prevent any recurrence. Thank you for your patience and understanding.
Posted May 20, 2025 - 12:30 MDT
Update
We believe we have identified the root cause and are rolling out a fix.
Posted May 20, 2025 - 12:19 MDT
Update
We are continuing to investigate the issue with loading on the frontend of the main application for a subset of customers. API access remains available as well as the mobile applications.
Posted May 20, 2025 - 11:38 MDT
Investigating
We're experiencing an elevated level of errors for a subset of customers on the main JobNimbus platform and are actively investigating.
Posted May 20, 2025 - 11:32 MDT
This incident affected: Login and Web Application Performance.