Pages may be slow loading

Incident Report for JobNimbus

Resolved

This issue has been resolved. Code released to production over the weekend contained a bug affecting the loading of Products & Services and Material Ordering. This was rolled back at 8.23a this morning and resolved the issue. Given the events of the previous week we kept the incident open throughout the day to monitor closely, but did not see recurrence nor the same performance issues.
Posted Sep 22, 2025 - 15:21 MDT

Update

All metrics and tests indicate healthy, normal operations, but we will leave this status open in Monitoring for a few more hours.
Posted Sep 22, 2025 - 13:43 MDT

Update

Observing some renewed degradation.
Posted Sep 22, 2025 - 12:26 MDT

Update

We are continuing to monitor, but see recovery.
Posted Sep 22, 2025 - 11:57 MDT

Update

We see improvements in our metrics and see improved site operations. We are continuing to monitor closely.
Posted Sep 22, 2025 - 11:24 MDT

Monitoring

We are closely monitoring site performance this morning. While operations are improved from last week some of our metrics indicate higher than average latency in certain layers of the system. We will post updates as we work the issue today.
Posted Sep 22, 2025 - 11:04 MDT
This incident affected: Web Application Performance.