System Temporary Unavailable

Incident Report for JobNimbus

Postmortem

JobNimbus Service Disruptions - December 11, 2025

On December 11th JobNimbus experienced two service disruptions that impacted your ability to access the platform.

First Incident (3:07 PM - 3:46 PM MST) A software release combined with a database indexing operation created a race condition that disrupted normal operations of database lookups and application performance.

Second Incident (5:50 PM - 6:12 PM MST) Following recovery, we deployed a follow-on release to improve performance and stabilize the platform, but detected unexpected errors in our calendar API and so initiated a rollback. During this rollback, a container replacement issue at our cloud provider resulted in insufficient healthy nodes to serve the application, causing a second outage.

What We're Doing Our teams have identified process improvements to prevent these issues from recurring, and we are implementing these changes this week.

We sincerely apologize for the inconvenience and disruption to your day-to-day operations. We understand how critical JobNimbus is to running your business and are committed to maintaining the reliability you depend on.

Posted Dec 15, 2025 - 10:11 MST

Resolved

This issue has been resolved. A write-up of the root cause will be posted within the next 2 hours.
Posted Dec 11, 2025 - 15:49 MST

Update

Observing recovery.
Posted Dec 11, 2025 - 15:30 MST

Identified

We have identified the issue that is disrupting JobNimbus operations. The root cause is identified and steps are actively being taken to remediate and restore operations.
Posted Dec 11, 2025 - 15:19 MST
This incident affected: Web Application Performance and Mobile Application Performance.