Intermittent Slowness and Instability on New Sales Experience

Incident Report for JobNimbus

Resolved

This incident has been resolved and estimating in the New Sales Experience is restored to full performance. Thank you for your patience and we apologize for the inconvenience.
Posted May 12, 2026 - 12:53 MDT

Monitoring

A fix has been implemented and application performance is restoring
Posted May 12, 2026 - 12:06 MDT

Investigating

We're experiencing intermittent slowness and instability with estimating in the New Sales Experience and are actively working to address the issue.
Posted May 12, 2026 - 11:31 MDT
This incident affected: Web Application Performance.