ACH Payments may not be processing for JN Payments
Incident Report for JobNimbus
Resolved
Payment processing has been restored to full service. Thank you for your patience!
Posted Apr 11, 2023 - 16:11 MDT
Investigating
Some companies may not be able to receive payments through ACH temporarily, we've identified the issue with our payment provider and are actively rectifying the issue.
Posted Apr 11, 2023 - 15:04 MDT
This incident affected: Receiving Payments.