Elevated API Errors

Incident Report for JobNimbus

Resolved

The issue is now resolved and we are seeing API error rates within acceptable thresholds.
Posted May 26, 2026 - 18:52 MDT

Monitoring

We have identified the issue and deployed a fix. While we are seeing initial recovery, we continue to monitor the situation.
Posted May 26, 2026 - 18:42 MDT

Investigating

We are seeing elevated error rates on our system, impacting material orders, activities, and other parts of the system. We are actively investigating and will update again shortly. We apologize for any inconvenience
Posted May 26, 2026 - 18:33 MDT
This incident affected: Web Application Performance and Mobile Application Performance.