We have confirmed the mitigating fix has had the desired impact and mobile users are now able to create activities on the latest version of iOS. A full RCA will be posted in the next 24 hours.
Posted May 11, 2026 - 16:14 MDT
Monitoring
We have deployed the mitigating fixes and are monitoring recovery.
Posted May 11, 2026 - 15:42 MDT
Update
We have confirmed the root cause and are taking steps to mitigate and resolve the issue. We will continue to monitor the status as the fix rolls out.
Posted May 11, 2026 - 13:17 MDT
Identified
We have identified a potential candidate for the root cause of the issue. We are determining the next course of action towards a resolution.
Posted May 11, 2026 - 12:56 MDT
Investigating
We are currently investigating this issue.
Posted May 11, 2026 - 11:35 MDT
Update
We are continuing to monitor for any further issues.
Posted May 11, 2026 - 11:32 MDT
Monitoring
We are aware of an issue where some mobile app users are unable to create activities such as notes on job records. This is affecting a limited subset of users on the latest iOS release. We have identified the issue and are monitoring recovery to the affected users.
Posted May 11, 2026 - 11:28 MDT
Update
We are continuing to investigate the root cause of the issue. We will provide an update by 12:30 Mountain.
Posted May 11, 2026 - 11:28 MDT
Update
We are aware of an issue where some mobile app users are unable to create activities such as notes on job records. This is affecting a limited subset of users on the latest iOS release. We are actively investigating the issue.
Posted May 11, 2026 - 10:49 MDT
Investigating
An issue with the latest iOS release was identified. We are investigating and will post a follow-on message shortly.
Posted May 11, 2026 - 10:48 MDT
This incident affected: Mobile Application Performance.