Discover Cards with JN Payments are experiencing degraded performance
Incident Report for JobNimbus
Resolved
Discover has resolved an internal network issue on their side and has restored service.
Posted Feb 06, 2023 - 16:18 MST
Update
Discover has informed us they are continuing to look for a solution at this time and does not have an estimated time of resolution.
Posted Feb 06, 2023 - 15:46 MST
Monitoring
We have been informed by our payment provider that there are potential transaction failures with Discover cards only. This is affecting only JN Payments when using a Discover card during payment.
Posted Feb 06, 2023 - 13:39 MST
This incident affected: Receiving Payments.