Users experiencing some slowness

Incident Report for JobNimbus

Resolved

Performance should be at normal levels.
Posted Mar 17, 2025 - 14:52 MDT

Investigating

Issue is currently under investigation.
Posted Mar 17, 2025 - 10:00 MDT
This incident affected: Login, Web Application Performance, Mobile Application Performance, Engage, QuickBooks Integration, Receiving Payments, Partner Integrations, Public API - Application Programming Interface and Email (Email - Outbound, Email - Inbound).