JobNimbus Payments inaccurately logged in JobNimbus

Incident Report for JobNimbus

Resolved

Payment processing has been fully restored at this time. Any affected transactions will be reviewed and resolved as necessary in a timely manner.
Posted Jul 17, 2025 - 23:06 MDT

Identified

We are currently experiencing an issue where payments are being successfully processed but not properly recorded in our system.
In the meantime, you can verify transactions directly in the Payrix Portal: http://payments.jobnimbus.com/
Our team is actively working to resolve this. We’ll provide updates as we make progress.
Thank you for your patience and understanding.
Posted Jul 17, 2025 - 15:49 MDT
This incident affected: Receiving Payments.