Elevated API Errors and Delayed Processing

Incident Report for JobNimbus

Resolved

We are observing full resolution.
Posted Oct 20, 2025 - 05:27 MDT

Monitoring

We are observing full recovery and are monitoring for any recurrence or disruption.
Posted Oct 20, 2025 - 04:47 MDT

Investigating

We are experiencing an outage due to some issues at the end of our public cloud provider. We are working closely with them to get this resolved or mitigated as quickly as possible. ETA is not known at this time but we are seeing signs of recovery in parts of our system.

We shall continue to share updates every hour, if not sooner.
Posted Oct 20, 2025 - 04:09 MDT
This incident affected: Web Application Performance and Mobile Application Performance.