Estimate creation and duplication instability in New Sales Experience

Incident Report for JobNimbus

Postmortem

New Sales Experience | Estimates duplicated or created are not populating in the estimate table


Beginning Wednesday, May 20 at 12:55 PM MT, JobNimbus users experienced disruptions to Nee Sales Experience estimate workflows. New and duplicated estimates were slow to appear in the estimate table for a job. No data was lost, only delayed. A smaller number of existing estimates also showed line items with the product association cleared. Customer impact was concentrated in the afternoon and was fully resolved later that evening.

The disruption was triggered by an internal product-update operation we ran for a single customer. The input data had a defect that caused our system to incorrectly flag a large set of product records for cleanup, and a bug in how that cleanup is processed turned a manageable workload into an overwhelming one. As a background process fell behind, users experienced this as estimates not appearing.

We restored service by stopping the operation, clearing the backlog, and adding a database optimization the background process needed. We are following up by fixing the cleanup bug, hardening our internal update tooling so an input defect like this cannot pass through silently, and adding production monitoring so this kind of pressure surfaces before it becomes customer-visible.

We are sorry for the disruption this caused, especially for customers who were working on estimates with their teams when the issue began. Thank you for your patience while we worked through it.

Posted May 21, 2026 - 18:23 MDT

Resolved

Estimates are now displaying in the Estimates table as expected. Thank you for your patience and we apologize for the interruption.
Posted May 20, 2026 - 16:20 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 20, 2026 - 13:59 MDT

Update

We are continuing to investigate this issue.
Posted May 20, 2026 - 13:14 MDT

Investigating

We are currently investigating an issue causing newly created or duplicated estimates in the New Sales Experience to not show up in the Estimates table on jobs.

No data is being lost, but processing is delayed.
Posted May 20, 2026 - 13:13 MDT
This incident affected: Web Application Performance and Mobile Application Performance.