JobNimbus is currently experiencing some issues
Incident Report for JobNimbus
Resolved
This incident has been resolved.
Posted Sep 10, 2021 - 18:19 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 10, 2021 - 18:15 MDT
Investigating
We are currently investigating some issues in JobNimbus.
Posted Sep 10, 2021 - 17:49 MDT
This incident affected: Web Application Performance, Mobile Application Performance, and Receiving Payments.