Slow Loading for Jobs and Contacts

Incident Report for JobNimbus

Postmortem

Resolved: Slow loading on Job and Contact pages (QuickBooks Online outage)

Status: Resolved Date: September 1, 2026 Impact window: ~2:00 PM to ~4:30 PM MT (intermittent) Impact level: Degraded performance

Summary

On September 1, Intuit experienced a widespread outage affecting the QuickBooks Online API. For about two and a half hours that afternoon, JobNimbus customers on our legacy QuickBooks integration saw Job, Contact, and Invoice records that had been synced to QuickBooks take one to two minutes to load, and sometimes fail to load. We shipped a workaround the same afternoon, and records were loading normally by about 4:30 PM MT, more than five hours before Intuit's own outage ended. Customers on our new QuickBooks integration kept working normally throughout. If you are on the legacy integration, you can move to the new one now; details are below. No data was lost or changed.

Root cause

Our legacy QuickBooks integration relies on a real-time check with QuickBooks Online when a synced Job, Contact, or Invoice is opened. When Intuit's API stopped responding, those records waited on QuickBooks, and that wait is what customers experienced as a long spinner that sometimes ended in an error. Records that had never been synced to QuickBooks did not depend on that check, which is why they loaded normally in the same accounts.

Resolution

We did not wait for Intuit to recover. About two hours after the first report, we had diagnosed the root cause, built a workaround in the legacy integration, and shipped it: Job, Contact, and Invoice records now open regardless of whether QuickBooks responds. Load times returned to normal at about 4:30 PM MT. Intuit's outage continued until roughly 9:45 PM, with JobNimbus records staying healthy for the remaining duration.

This workaround addresses the specific failure that Intuit's outage exposed. The legacy integration still relies on real-time checks with QuickBooks elsewhere in the product. Our new QuickBooks integration was designed to avoid that dependency from the start, which is why it was unaffected.

The even better news: our new QuickBooks integration is ready for you

We built our new QuickBooks integration so that your day-to-day work in JobNimbus never has to wait on QuickBooks. Customers on the new integration saw the payoff on September 1: Jobs, Contacts, Invoices, search, and boards kept loading normally throughout Intuit's outage. It is also a better integration day to day: it syncs faster, is more reliable, and keeps your financials more accurate.

If you are on our legacy QuickBooks integration, the new integration is the right next step, and we would love to help you move. Our team is ready right now:

  • A dedicated QuickBooks team at JobNimbus Support handles the move for you.
  • No interruption to your daily work. We make the switch on the backend. Your workflows and settings stay exactly as they are, and you only change things if you want to.
  • Built so you can run your business without disruption. Your Jobs and Contacts stay fast even when QuickBooks is down.

To get started, contact JobNimbus Support and ask about moving to the new QuickBooks integration:

We will take it from there.

You run your business on JobNimbus, and we take that seriously. Keeping your operations moving is the standard we hold ourselves to, on ordinary days and on days like September 1. Thank you for your patience and understanding while we worked, and for your continued trust and support.

--------

Additional Details

Impact

Affected users experienced:

  • Job, Contact, and Invoice records that had been synced to QuickBooks showing a loading spinner for one to two minutes before opening, or not opening at all.
  • Jobs not appearing from search or from boards in some accounts.
  • Occasional errors when creating or updating a Job in affected accounts.
  • The Accounting Settings page failing to load, while other settings pages loaded normally.

The slow record loads were limited to accounts on our legacy QuickBooks integration, and even there, unsynced records and estimates loaded normally. The Accounting Settings page connects to QuickBooks directly, so it could load slowly for any account connected to QuickBooks, including those on the new integration. The impact was intermittent: many record loads still succeeded, but a significant share did not.

Timeline (Mountain Time)

  • ~2:00 PM: Intuit's QuickBooks Online API incident begins, with intermittent timeouts across their services (times on Intuit's page are Pacific). Synced Job, Contact, and Invoice records begin loading slowly.
  • ~2:30 PM: First customer reports reach our support team. We open an incident and begin investigating.
  • ~2:45 PM: We post the first update to our status page.
  • ~3:05 PM: We confirm Intuit's outage as the trigger and link to their status page.
  • ~3:20 PM: We identify the root cause: records were being held up by QuickBooks.
  • ~4:05 PM: Workaround approved and deploying to production.
  • ~4:30 PM: Workaround live; records load normally again. Incident resolved shortly after.
  • ~9:45 PM: Intuit resolves its incident.
Posted Sep 02, 2026 - 19:52 MDT

Resolved

The issue impacting the loading of Jobs and Contacts for some QuickBooks-connected accounts has been resolved.

The incident initially began with an outage affecting QuickBooks services. During our investigation, we identified that some legacy QuickBooks integrations in JobNimbus were making live requests to QuickBooks when loading Jobs and Contacts. As a result, the QuickBooks outage could prevent those records from loading properly in JobNimbus.

Our team has updated this behavior so JobNimbus can rely on internally stored synchronization data rather than requiring a live QuickBooks response when these records load.

Jobs and Contacts should now load normally. We’ll continue monitoring to ensure the fix remains stable.

Thank you for your patience while we worked through this issue.
Posted Sep 01, 2026 - 16:49 MDT

Monitoring

We launched a fix and are seeing jobs and contacts load again
Posted Sep 01, 2026 - 16:40 MDT

Update

We have identified a fix that would allow jobs and contacts to load regardless of QuickBooks status.
Posted Sep 01, 2026 - 16:09 MDT

Identified

We’ve identified that the slow loading affecting Jobs and Contacts appears to be related to an ongoing QuickBooks Online API incident. Intuit is currently investigating intermittent timeout errors affecting their services. We are monitoring the situation and will provide additional updates as they become available.

Fro additional Context and monitoring:
https://status.developer.intuit.com/incidents/ppq8m14fqzq5
Posted Sep 01, 2026 - 15:04 MDT

Update

We are continuing to investigate this issue.
Posted Sep 01, 2026 - 14:55 MDT

Investigating

We are investigating reports of slower-than-normal loading times for Jobs and Contacts. Our team is actively working to identify the cause and restore normal performance.
Posted Sep 01, 2026 - 14:45 MDT
This incident affected: Web Application Performance.