We root cause has been resolved and backend processing is caught up. We will post an RCA summary within 48 hours. We apologize for any inconvenience. Thank you.
Posted Jul 13, 2026 - 19:47 MDT
Update
We continue to work on backend changes to ensure no recurrence and resolve all lingering queues. Platform is operational.
Posted Jul 13, 2026 - 17:26 MDT
Monitoring
The root cause has been fully identified and isolated. We are pushing fixes to resolve all remaining backend queues and are monitoring impact. We will keep the incident open until this work is fully completed.
Posted Jul 13, 2026 - 15:57 MDT
Update
Backend performance metrics have improved to normal operations along with a reduction in error rates. We are still observing delays some asynchronous processes, but the web application and mobile application are up and operating. Work on full resolution continues and updates will still be posted within 30 minute intervals. Thank you for your patience.
Posted Jul 13, 2026 - 15:31 MDT
Update
The in-progress mitigation is working through a backlogged queue to restore normal operations. Current ETR is ~3:20pm.
Isolation and full resolution of root cause is still in progress.
Posted Jul 13, 2026 - 14:53 MDT
Identified
Mitigations are in place to restore operations while the root cause is addressed. We are observing improvements in backend query times as well as a reduction in error rates. Thank you for your patience.
Posted Jul 13, 2026 - 14:31 MDT
Update
Teams have identified a possible root cause and are working on resolution and possible mitigations to restore service.
Posted Jul 13, 2026 - 14:10 MDT
Investigating
We are currently observing elevated errors and degraded performance in the backend of the JobNimbus web and mobile applications. There may be disruptions to the viewing of estimates from the jobs page or the creation of new records. Will post status updates every 15 minutes until resolved.
Posted Jul 13, 2026 - 13:55 MDT
This incident affected: Web Application Performance and Mobile Application Performance.