A backend release to our Material Orders system resulting in material orders to not display. The bug was in the endpoint the app.jobnimbus.com frontend calls for display, all other Material Order endpoints were functional. To resolve the release was reverted and a stable version was pushed to Production. The teams are running a post-mortem to determine what changes to our testing and release process are necessary to prevent recurrence.
We appreciate your patience and apologize for the impact on operations.
Posted Nov 07, 2025 - 10:19 MST
Resolved
Issue has been resolved. A write up of root cause will follow.
Posted Nov 07, 2025 - 09:23 MST
Identified
We have identified the issue and a releasing a fix
Posted Nov 07, 2025 - 08:54 MST
Investigating
We are currently investigating an issue where Material Orders are not displaying on certain screens. API calls confirm the records are available and saving, but are displaying. We will provide updates as the issue is worked.
Posted Nov 07, 2025 - 08:33 MST
This incident affected: Web Application Performance.