Issue with our service provider

Incident Report for JobNimbus

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:13 MDT

Update

We are seeing normal operations restored to JobNimbus (including Engage). We are monitoring the platform closely and validating application health as we have not yet received an all clear from our Cloud Partner. Thank you for your patience.
Posted Oct 20, 2025 - 15:12 MDT

Update

We are continuing to see improvements and users should be able to use JobNimbus features excepting Engage; which we are working on restoring to full functionality. We are continuing to monitor the AWS platform for full notice of recovery.
Posted Oct 20, 2025 - 14:57 MDT

Update

We seeing early signs of recovery from the continuing AWS event. We are working on restoring key services but do not have an ETA at this time. We are working closely with our Cloud Partner to provide information as soon as we can.
Posted Oct 20, 2025 - 13:57 MDT

Update

We are continuing to work with our Cloud partner on restoring service.
Posted Oct 20, 2025 - 12:03 MDT

Update

The continuing AWS event has caused further disruption to the JobNimbus application. We are taking additional steps to restore service.
Posted Oct 20, 2025 - 09:56 MDT

Monitoring

AWS' [1] ongoing incident has disrupted operations of our Engage application and some of our auto-scaling mechanisms. Mitigations are being attempted and we are monitoring the situation closely.


[1] https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 08:05 MDT
This incident affected: Login, Web Application Performance, Mobile Application Performance, Engage, QuickBooks Integration, Receiving Payments, Partner Integrations, Public API - Application Programming Interface and Email (Email - Outbound).