Estimate Presentation Delays

Incident Report for JobNimbus

Resolved

All processing has complete and the Estimating application is operating at full functionality. Thank you for your patience. Please see the 11:53am Incident for a root cause summary.
Posted Jun 20, 2025 - 15:21 MDT

Identified

A processing backlog from the earlier Estimates disruption is causing delays when viewing of a newly created or duplicated estimate. We will post a message here when this is fully resolved.
Posted Jun 20, 2025 - 14:03 MDT
This incident affected: Web Application Performance.