Estimate Update Delays

Incident Report for JobNimbus

Resolved

Estimate updates have returned to normal processing. Thank you for your patience.
Posted Apr 10, 2026 - 10:44 MDT

Monitoring

We’re currently seeing degraded performance that is causing delays in estimate updates.

Changes made to jobs may take longer than normal to appear in estimates. There is no data loss, and customer data remains safe. At this time, the impact is limited to delayed processing and delayed updates appearing in the system.

We’re actively monitoring this and will provide additional updates as we learn more.
Posted Apr 10, 2026 - 08:51 MDT
This incident affected: Web Application Performance.