Engage Message Loading

Incident Report for JobNimbus

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 13:41 MDT

Identified

The issue is stemming from a 3rd party software. We're working with them to restore full functionality. We did a temporary adjustment to allowing viewing of conversations for now but real-time messaging is temporarily impacted. Your messages are safe — refresh to see the latest messages. Mobile is unaffected.
Posted Apr 20, 2026 - 11:17 MDT

Investigating

We are currently seeing Engage conversations are failing to load on web. We are actively investigating to resolve.
Posted Apr 20, 2026 - 09:12 MDT
This incident affected: Engage.