Search Bar

Incident Report for JobNimbus

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 10:36 MDT

Identified

We’re currently investigating an issue where Search continually loads for some users. We’ve reproduced the issue and are actively working to get this fixed. We’ll provide updates as they become available.
Posted Apr 21, 2026 - 10:22 MDT
This incident affected: Web Application Performance.