Payments Portal Degradation

Incident Report for JobNimbus

Resolved

The partner has identified and resolved the issue.
Posted Aug 21, 2025 - 14:38 MDT

Investigating

Some users may experience slowness or difficulty accessing the payment portal due to an issue with our payment provider, Payrix. Transaction processing is not affected. Payrix is aware and actively working on a resolution.
Posted Aug 21, 2025 - 13:29 MDT