ABC Integration Branch and Job Account Fail to load

Incident Report for JobNimbus

Resolved

ABC rolled back a change they made which resolved the issue
Posted Jul 21, 2026 - 09:41 MDT

Identified

We’re investigating an issue where ABC branches and job accounts are not populating. We're working with ABC now to get this addressed
Posted Jul 21, 2026 - 09:26 MDT
This incident affected: Partner Integrations.